11/27/2019

Slow Transfers QNAP NAS on a Gigabit Network

For several months or possibly years transfer rates from my QNAP nas TS-231 have been very slow about 12.5MBps to 15MBps (that's megabytes per second). I have a gigabit network and transfer rates should be above 50MBps.

I won't go in to all the ridiculous things I tried based on other people having the same issue, here is what fixed mine:

After opening a ticket with qnap 2 months ago and dealing with their SLOW response times I finally got a resolution to my problem.

The last thing they asked me to do was to disable server signing. No explanation of what exactly they were referring to, no information on where to find this setting. nothing useful.

I spent a couple of hours googling how to disable server signing on a qnap with nothing useful being found. I tried editing the smb.conf (this appears to be where the setting is), but the qnap changed my settings back upon a reboot of the server.

after much more googling I kept finding references to server signing with windows, which led me to try something.

My qnap was set as an Active directory domain controller, I did that because I kept having problems getting access to my own files.

I turned off AD domain controller and of course that broke access to my files.

I also had to disable Windows ACL support since I could not access my files, take ownership of them or anything, I enabled Advanced Folder Permissions.

I did manage to join the qnap to the domain, something that never worked before. I do not know why it is working now.

I was then able to set permissions of my files in the qnap webpage and finally access them.

I noted that server signing is now disabled in the smb.conf file (not by me).

I tested copying files and wow look at that transfer rates of about 60MBps.

It only took over 2 months and countless hours googling the issue. Was it server signing? was it my qnap being a domain controller? not sure but it's working now.

10/30/2019

SYSTEM_SERVICE_EXCEPTION 0x0000003b termdd.sys BSOD and possible cause

Starting a few days ago I began getting Blue screen of death with my Windows 7. The error was as below
SYSTEM_SERVICE_EXCEPTION 0x0000003b
00000000`c0000005

Sometimes the cause (per bluesreenviewer) was either termdd.sys or ntoskrnl.exe. Initially it was a lot of ntoskrnl.exe but then lots of termdd.sys began showing up.

now I had googled the issue and there was the standard "it's your memory", "bad video drivers", or "run SFC /SCANNOW" guesses at fixes for people.

I updated my video drivers.
I did a malware scan and found nothing.
I did a memory test and found nothing wrong (memory test are mostly useless).
I did SFC /SCANNOW (this is what people tell you to do when they don't know how to help) it also found no major problem just one unrelated corrupt dll.
I installed all current updates.
I restored my computer to a couple of days before the problem occurred.
Nothing worked.
I then did some thinking and realized that most of the issues were with termdd.sys, well I had my Remote desktop open to the internet. I remembered that my port 3389 is often hammered from china So I closed port 3389 on my firewall and the issue disappeared.

After further research I found that there is a vulnerability that is supposed to have been patched for windows RDP, but apparently not.


9/16/2019

EnGenius Wireless Access point stops working

If you have an EnGenius Wireless Access Point wifi that stops working properly and has to be reset frequently this may solve your problem. You may login to the device and everything appears to be fine yet nothing will connect to it or it may not even show as a device to connect to.

The cause:
Many EnGenius WAP's have a problem where after several days or even hours of use the access points are not freeing up some resource internally. I do not know exactly what. I found a forum post many months ago that explained it but I cannot find it again.

The solution:
Upgrading the firmware does not help and on some models they are End Of Life and updates are not available. You can put them on a timer that disconnects power for a short time every night when they are not used, or you can write a script that reboots them.

You will need:
TST10.EXE
A folder under C:\windows called script
put tst10.exe in C:\windows\script\
Create a text file for each device you want to reboot.
C:\windows\script\ecbcom.txt

the contents of the file should be:
x.x.x.x 23 replace the x's with you devices IP keep the space and 23
WAIT "Name:"
SEND "admin\m"
WAIT "Password:"
SEND "youradminpassword\m"
WAIT "cmd>"
SEND "reboot\m"
WAIT "cmd>"

Create a batch file in C:\windows\script called tst.bat
the contents of that file should be:
c:
cd\windows
cd script
call tst10 /r:ecbcom.txt

Create a task schedule to run and execute the tst.bat file at the time you want to reboot the access point. I tried the timer method but that was causing problems with my "smart" thermostat, the batch file method is faster and my thermostat does not complain as the reboot happens very quickly. Since implementing this (9 months ago) I have only had to physically power off and on the access point once. My reboots happen every Monday, Wednesday, and Saturday at 4am.

9/11/2019

BSA Red Dot RD3022SB Gummy Sticky problem

Recently I happened across my BSA Red Dot  RD3022SB site which I had not used in many years. It was stuck in a drawer in my work room. I went to pick it up and it was horribly sticky. It seems it was coated with some kind of non slip compound that for unknown reasons had turned gooey.

Using my googlefu I found many forums with people reporting the same issue. most of them just got rid of the site saying it was impossible to clean. Other people reported it could be cleaned with alcohol but that was very laborious. Many people reported that Acetone did not work.

Here is what I did to clean mine.

You will need:
Real Acetone (your wife or girlfriends fingernail polish remove is NOT acetone).
Denatured Alcohol.
Thick Nitrile or Rubber gloves (5 mil or thicker).
rough paper towels.
q-tips.
a respirator or work outside.
Patience.

Put on the gloves and respirator (acetone is not good to breath or have on your skin).
If you have the lens caps put those on so you don't get acetone on the lenses.
Pour a liberal amount of acetone on a folded up paper towel and begin soaking and scrubbing the goo off. It will take several passes to remove it. You will know the gunk is removed when you see the greenish black anodizing under it. I was able to go over all the surfaces and no paint or anything was removed that I did not want removed.

Now go over all the cracks and crevices with q-tips until no more black stuff comes off on to the q-tips.

Remove the lens caps and using q-tips carefully clean around the area that was covered by the lens caps and around the lenses (avoiding contact with the lenses).

Next put the lens caps back on and drench everything with the alcohol and wipe that off. clean the lenses with soap and water. You are done.


9/09/2019

Clock Vacuum Fluorescent Display Cross Reference

Here is a list of clocks that use Vacuum fluorescent displays, the type of clock chip, the make and model of the VFD, and display features.

Cosmo Time E-508, Clock chip LM8361 G4 (same pinout as a TMS1943N2l or NTE2060) , VFD Futaba 5-LT-16, 4 digit 12 hour only colon AM PM.


Sunbeam (unknown model), clock chip TMS3451NL, VFD Futaba 5-LT-79ZS/81, 4 digit can display 24 hour AM PM sleep alarm dot after last digit.

General Electric 7-4265A AM/FM/Cassette under cabinet clock radio, clock chip TMS3451NL, VFD Futaba 5-LT125Z, 4 digit can display 24 hour colon AM PM dot after last digit.

General Electric AM/FM clock radio 7-4642A, clock chip 8RS8600 (possibly same pinout as TMS1943N2l or NTE2060) , VFD NEC FIP5K15S 4 digit can display 24 hour colon AM PM alarm indicator.
  

5-LT-31 2A
5-LT-31/33
Unknown what it came out of.
Futaba 4-BT-04 8A
From a Heathkit GC-1415 clock
 
5-LT-02 B3 from an unknown unit
 
If you have information on a VFD display that you would like to add, please leave a comment on where I can get:
Pictures of the front and back of the display
Manufacturer and model number of the device it came out of.

6/24/2019

The Worst Car Radio/Stereo in the World

I have a 1989 Chevrolet c2500 that someone took out the original stereo and head unit and replaced it with (what I would describe as) the worst radio I have ever used.

The radio was a Pioneer DEH P400UB I hate this thing with the hate of a thousand suns. Attempting to do anything with it while driving results in nearly wrecking the truck.

Replacing the OEM unit appears to be more trouble than it would be worth.


After lots and lots of searching I finally found a good simple to use stereo.

I got a used stereo from a 1998 Subaru Legacy. It was one of the few stereos I could find that also had lots of information online. 20 watts per channel, 4 channels, cassette tape, lcd display and simple easy to use controls.


The unit looks brand new inside and out, mounted it this morning and was able to drive around manipulate the controls with out hardly looking at it and never once came close to wrecking as with the Pioneer.

Also sound real good not quite as sensitive as the one in my 2015 forester. Made by Panasonic.

I have a cassette tape that can connect to an external device, a cassette that can do bluetooth, and a cassette that can play mp3's.
bluetooth
https://youtu.be/qBDZghOVnsM
mp3
https://youtu.be/HtoP7a615EA




I took the Pioneer radio and put it on my bench to mess with it. Even sitting on my bench where I can give it my full attention I cannot control it easily. It has a single knob that is also a joy stick and a button. It has a remote control but that still does not make it easier.

It works like this when in tuner mode:
the knob is rotated for volume
you move the knob left and right to tune a station
moving the knob up and down selects presets.
the problem is when you try to do this while driving you have to remember what does what and the slightest wrong movement will result in changing the station or moving it off frequency.

Then there is the problem of mistakenly enabling demo mode. if that happens the radio can't be turned off and you have to consult the manual to do that but the manual skips steps and is badly written.

then the other buttons on the radio have multiple functions which change depending on what you are doing. The Pioneer DEH P400UB is a $200 driving hazard distraction radio from hell. Though it does sound good it does not belong in a car.

Don't get me started on the trouble it is just to change balance, fader, and tone controls.

4/08/2019

I built a spot welder

Using a car battery and other stuff

12/24/2018

JVC DR-MH30SU HDD DVD Recorder Power Supply repair

Here is a video I did of my repair of the JVC DR-MH30SU HDD DVD Recorder Power Supply.
link to service manual: https://www.dropbox.com/s/wrbqfx8o73ld0ei/jvc_dr-mh20su_dr-mh30su_dr-mh30stw_full_sm.pdf?dl=0
When it asks you to login or create an account click "no Thanks, Continue to View"
Then Click Download in the upper right corner.

11/18/2018

Thanksgiving and black Friday

Just say no.

4/08/2018

Makita to Skil/Bosch Battery Adapter build

I had a bunch of Skill cordless tools but no battery for them, instead of buying batteries and a charger I found a way to make an adapter to connect my Makita battery to these tools


There are USB adapters for other manufacturers that you could do this with.
Milwaukee
Dewalt
Ridgid
You could make many combinations of adapters.

3/16/2018

Clarion RF-484I Connector Pinout

I recently acquired a Clarion RF-484I (FCC ID AX292ARF484I) made for a mid 1980's Subaru (not sure which one). This is a single speaker mono radio (no stereo). The wiring diagram pinout is below. Mine had a connector that had a Blue wire for +12v, Yellow Speaker wire, white and black wires that are bridged and then go to case or common ground, and then 2 wires Red with green stripe, and Red with Blue stripe, for the dial light, it does not really matter which wire is positive or negative since they are independent of case ground or any internal circuitry in the radio. Speaker ground can be to the white wire, or to chassis ground anywhere in the car. There is a small screw on the front of the radio near the AM FM words that is used to tune the antenna for AM reception, mine did not seem to do anything. The way you use it is tune a weak AM station (or your favorite) and turn the screw till it sounds better.
The unit seems to use a max of 200ma at 13.8 volts DC without the dial light. Sound quality is fine for a mono radio, it has Volume, Tone, and push button tuning. To set the buttons. tune a station, pick a button, pull it out, then push it all the way in. Unknown if buttons can be programmed for both AM and FM (probably not). Push the volume knob in to turn on and off.

10/21/2017

foodinsurance.com 2 weeks supply emergency food review

foodinsurance.com 2 weeks supply emergency food review

9/22/2017

Video review of the ebay XH-M604 charge controller.

9/20/2017

TLDW wrapup for the small DC generator

Followup video for the dc generator build.

8/05/2017

Starter Circuit and Charge Controller for a small DC generator or solar panel

For about 3 weeks I have been working on building a box for a small DC generator I am building out of an old weed eater engine and a motor from an electric wheel chair.

This is the basic schematic:
These are the videos of the process of making it. They are rather long.

6/08/2017

Little White DOT

See that white dot in the picture above?
That’s a picture of Earth taken from Saturn.
Now tell me again how important your problem is?

6/03/2017

Looks about due for hard times.

Hard times create strong minds.
Strong minds create good times.
Good times create weak minds.
Weak minds create hard times.

4/22/2017

Droid Turbo XT1254 no sound from external speaker

Droid Turbo XT1254 no sound from external speaker.
My Droid Turbo recently stopped playing sound from the external speaker, and starting about 1 or 2 months ago the flash light stopped working.

Some googling produced an article that mentioned that someone had a similar problem and they found that if they pressed on the back of the case near the camera the external speaker would start working. I found that mine exhibits the same behavior. I opened up my phone to see if I could possibly fix the problem, and found the cause The battery is swelling up. It appears that the swelling is separating some connections. This may be the cause of the back lights not working as well.

The problem might be fixable but my phone is eligible for an upgrade and I don't want to mess with it.


3/28/2017

Hackaday Write up

I submitted a post from my blog to Hackaday and they liked it, read about it here.

Read the comments.

3/09/2017

General Electric 3-5251A Boom Box adding mp3 and bluetooth

I got this from ebay:
 I was looking for a boom box that I might be able to add bluetooth and maybe mp3 player abilities. It seemed it might be a good candidate for the addition of an internal or maybe an external device on the back.
 Although you cannot tell from the picture above there is only 2 possible locations to install something, one at the top behind the tape buttons, and a small location below the 2 inputs on the back (lower middle).

After looking on ebay for possibilities it became clear that it would be too complicated (and destructive?).

I did some research and found these 2 items on ebay:
a bluetooth adapter in a tape cassette.
http://www.ebay.com/itm/322385616259?_t ... EBIDX%3AIT
and an mp3 player (with remote) in a cassette.
http://www.ebay.com/itm/252509649751?_t ... EBIDX%3AIT

The next problem was when I tried to play a tape (it would not move). If it would not move the mp3 and bluetooth player would not work. I found that the source capstan was almost frozen and the take up was stiff. Some judicious applications of light oil and some moving things back and forth freed it up enough that it played a tape just fine. Pretty good for a 32 year old boom box.

The next issue was that when you pressed play on the tape there was a loud crashing static sound and one of the channels (usually the left one) would not work or fade out after a while. I was worried that there was a problem with the amplifier or maybe the play head on the tape recorder. I opened the unit up and was surprised at how easy it can be worked on. 7 screws hold on the back, the power supply is in the back panel and is plugged in to the mainboard, and there is a connector for the speakers.
4 screws hold the chassis in the unit, then a handful of screws hold the mainboard to the frame. the tuner wheel can be disconnected and then I secured it with a bread tie so I would not have to restring it. I cleaned all the pots and switches including the switch hidden near the play button. I checked a random electrolytic capacitor and found it was at it's rated capacity and had low ESR so I left them all alone.

I reassembled it, and tried the mp3 and bluetooth players and now there is no crash when I hit play and neither channel fades.

She sound great.